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This document is an introduction to the use and capabilities of Observer. In this document we will focus 
on the basic use of Observer for some popular and common applications. We encourage you to read this 
whole document before starting to use Observer. There are some helpful setup tweaks and best practice 
settings in Appendix A.  
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Download and Install the Observer Software  
  

The user running Observer—as well as the user installing the software—must have local 
Administrator rights on the Windows system. You can install the Observer analyzer software on a 
virtual machine so long as it meets the system requirements. The installation process is the same.  

  
Suggested User PC requirements  

 
  

1. Obtain the latest Observer installation image from the FTP site.   
2. From your browser, ftp://ftp.networkinstruments.com/pub/downloads/observer/ 
3. Download the Observersetup.exe file to your PC  
4. Run the ObserversetupX64.exe file and follow the on-screen instructions.  
5. Choose to install Observer.  
6. After the software has been installed on your system you must restart Windows. You will not be 

able to run Observer until you restart your computer.  
7. Launch Observer. Install the license file from the main menu Help>License Observer. Select 

Enter Name, be sure to use the exact Contact/Department and Company as specified in the 
license information file. Use the cut and paste option to help eliminate any errors. Then enter 
license number. Follow the instructions provided with your Network Instruments License file to 
install the license and complete the process. Each user must use unique license file credentials 
for this step (you can’t use the same license file for multiple users).  
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Understanding the Observer User Interface  
  

The Observer interface consists of a top Main Menu, a Probe list window on the left, and a Tools 
window on the right, and a Log window on the bottom.  

  
Probe Window – The area along the left hand side of Observer, where local and remote Probes, 
NetFlow, sFlow, and SNMP devices can be selected.  

  
Tools Window – The large window on the right where statistics, trending, decode, expert, and all other 
tools will be displayed. Many tools will have a Settings button that can be used to customize the tool.  

  
You can customize the display by selecting and dragging the separator lines between each of the 
windows. You can also customize which windows are displayed by selecting View from the Main menu  

  
To use Observer, simply select the desired probe you wish to work with, and then select the desired 
tool from the Main menu such as Statistics or Capture. You can have multiple tools running 
simultaneously for each selected probe. Each tool will be a separate tab at the bottom of the tool 
window. Some tools will also have additional tabs along the top or bottom to provide additional 
functionality and display options.  

  

  
  
  
Important Tips:  

• You can close any tool by right clicking on the tool tab in the tool tray and select 
Close. • You can close all tools - from main menu Window>Close All Statistics 
Windows  

• Press F1 for context sensitive help and descriptions at any time.  
  
Now that you have an understanding of the Observer user interface lets discuss probes and some 
common tasks for monitoring and analyzing your network.  
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Adding Remote Probes or a GigaStor to Your Observer  
  

Your Observer may have local software based probes included with it. Only one user at a time can 
work with each probe instance. Just select the desired probe to work with it.  

  
You may also desire to add remote probes such as a GigaStor or another probe to your Observer. From 
the main menu, select Actions>Redirect Probe Instance, then select New and specify the IP 
address of the probe, the default username/password is left blank. Then OK.  

  

 
  
Select the newly added probe and then Redirect Selected Probe Instance. Select the desired 
instance, then Redirect Selected Instance, then Redirect to your Observer. Multiple probe 
instances can be created, maximum is 64 to allow multiple users to use a single probe, please refer to 
the user guide for additional information on this topic.  
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Viewing Live Statistics  
  

In Observer, real-time statistics are gathered by viewing—not capturing or trending—network traffic 
and incrementing a statistic counter. Statistics are particularly useful for determining network health. 
For example, real-time statistics can display the number of errors occurring on your network, the 
number of established connections, and the bandwidth utilization across the network. GigaStor users 
can view Statistics from the GigaStor Control Panel  

  
From the main menu, select Statistics>Top Talkers (or any statistics tool of interest). Then press the 
Start button to begin capturing statistical data.  

  
Notice the Start, Stop, and Settings buttons for the statistics tool (top). In the example below there 
are 3 separate statistics tools running, each with its own tab in the Tool Tray (bottom). Simply select 
the tab of the desired tool to display that statistics window. Also note that by dragging the vertical line 
between the probe and tool window, the window sizes can be adjusted.  

  
Right click a row to bring up additional options (center) like create filters or do a packet capture on that 
station.  

  

  
  
Try out the various statistics tools based on your interest.  

• Press F1 for a detailed description of each statistic tool  
  
VLAN Statistics- shows the (VLANs) operating on your network.  
Top Talkers Statistic- lets you see who is using the most network bandwidth.  
Protocol Distribution Statistic- displays all protocols running on the network.  
Internet Observer- show what websites users are visiting and how much time was spent on a 
website.  
Internet Patrol- allows you to view MAC to IP communication as a list, pairs circle, or charts 
Wireless environments-There is several statistics windows tailored to provide information that is 
characteristic or unique to wireless networks. Wireless Site Survey and Wireless Access Point 
Statistics are available only for wireless interfaces and common statistics such as Top Talkers and 
Vital Signs contain wireless tabs that are only available when monitoring a wireless interface.  
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Understanding the GigaStor User Interface (for GigaStor probes only)  
  

From the Main menu, launch the GigaStor Control Panel by Capture>GigaStor Control panel.  
The top section is a chart of the GigaStor data for the time frame that is selected by the GigaStor 
slider. The middle buttons control the data display and resolution of the top chart. The bottom section 
is the reports and statistics for that time frame. Drag or expand the slider to define the time frame of 
interest then press the Update Chart or Update Reports button to update your information to the 
new time frame. Right clicking in the top chart will bring up additional controls.  

  

  
  

Important Tips:  
• Press the Settings button. Under General Options, uncheck Enable Analysis types you are 

not using like 4G LTE, FIX, etc. This will remove them from the Reports/Statistics Ribbon.  
• Use the left/right arrow on the Reports/Statistics ribbon to move it to the right to see the 

 expand window button. Pressing this button will maximize or minimize the 
Reports/Statistics section. Now you can easily view the reports and statistics for your 
selected time frame.  

• You can filter or select a specific area of interest, such as HTTP. Check boxes of desired 
traffic, then press the Analyze button which will launch the Expert Analysis and decode for 
HTTP only (Be sure to specify the Analysis option – Filter Using Selected GigaStor Entries).  
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Capturing Packets  
  

After packets are captured, you can use Expert analysis to look at all packets and identify network 
problems and to help determine the best course of action. Expert Analysis is like having a network- 
troubleshooting expert on site to tell you what the packet captures mean. It can help you determine 
whether saturated bandwidth or overloaded servers are causing user-reported delays. With Expert 
Analysis, you can look at a conversation to see exactly where the errors or delays are occurring.  

  
For Observer probes, click Capture>Packet Capture from the main menu, then click Start; if 
desired, filters can be defined before the capture from the main menu - Actions>Filter Setup for 
Selected Probe. Capture options like buffer size and where to save packets can be modified from 
Settings (see appendix A). At any time during the capture, you can press the Decode button to open 
the Decode window. Once you do so, the expert analysis and decode window is displayed.  

  
For GigaStor probes, click Capture>GigaStor Control Panel  

• Adjust the slider to select the time frame of interest for capture/decode  
• Press Analyze and be sure to specify analysis options to Analyze all data or specify Filter 

Using selected GigaStor entries if you had previously specified a filter. Or select an existing 
filter. Analysis type should usually be Expert Analysis and Decode, then OK  

  

  
  
Important Tips:  

• To find a SIP based VoIP call, use the VoIP and Videoconferencing calls by SIP tag analysis 
option, then Settings, to mine a specific call in its entirety for analysis.  
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Expert Summary  
  

Press the Expert Analysis tab (bottom left) and then Expert Summary (top left) for the summary 
screen. The Expert Data buttons let you view and select various types of events relevant to the given 
type of protocol: TCP, UDP, SCTP, ICMP, and VOIP and Video conferencing.  

  
The Analysis buttons let you display various analysis reports on the selected expert event. These 
analysis reports are also available by right-clicking on the event and choosing the desired menu option.  

  
After analyzing each packet and every conversation detected, Expert Observer lists any problems or 
other events of interest it found from the data collected. The Expert Summary lists some of the more 
general, non-conversation specific problems that Observer found when analyzing the packet capture. 
Expert Observer can detect over 700 expert events for explanation and notification. Note the additional 
tool options shown at the bottom.  

  

 
    
  
  
Right-click any event and a pop-up menu like the following is displayed:  

  

 
  
Show Condition Data - takes you to the selected Expert Event in the TCP, UDP, SCTP, ICMP, and VOIP 
and Video conferencing display. From there, you can take a closer look at the data and the connection.  

  
Expert Explanation - pops up a window that explains what the event means (e.g., defines what a 
"TCP Slow Response" is). The window also explains why the event might be occurring (e.g., 
"overloaded network"), and suggests solutions where possible.  
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Expert Analysis and Data  
  

Let's take a closer look at Expert Analysis. First, click the TCP Events button to display TCP Events:  
  

  
  
There is a lot of information being conveyed here to help you assess network, server, and application issues. 
In this example we are focusing on HTTP; pressing the Status column label sorts by red to green or green to 
red to quickly show all of our problem HTTP sessions. We can sort by Response times by pressing the 
Response time label. The metrics that are problematic are flagged by red or yellow colors.  
By selecting (clicking) a particular session, you can get the expert analysis of that particular connection.  
The detailed Response time metrics quickly show you by direction, the client and server response times. The 
Network delay metrics quickly show you by direction, network latency. Retransmission stats tell if a network 
is unreliable or if packets are being dropped. This helps determine if the server is responsible for poor 
performance or if it is the network. If you right click on your connection, you are presented with additional 
troubleshooting tools such as Ad Hoc Application Transaction Analysis, Connection Dynamics, etc, that will let 
you dive deep into the details of the session. Select Expert Explanation for details on a column metric. 
Please reference the Observer user guide for detailed information on each of these tools.  

  
Connection Dynamics - tracks a conversation graphically along a timeline, visually representing each packet. 
The timeline format lets you quickly see long latencies and delayed response times.  

  
Ad Hoc Application Transaction Analysis (ATA) - Using Layers 5-7 of the OSI Model, ATA allows you to 
monitor response time, error, request and response trends for any supported server application protocol.  
Observer supports most major application protocols including, SQL, HTTP, LDAP, DNS, VoIP and more. Add 
Server to Application Transaction Analysis for continuous monitoring.  

  
Fast Post Filter - allows you to filter based on the selected connection.  

  
Important Tips:  

• Save packets by selecting the Decode tab (bottom), then pressing Tools>Save Capture Buffer  
• From Settings>TCP/IP - change your settings to match those shown below (suggested)  
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Expert Analysis - Using Connection Dynamics  
  

Connection Dynamics show a selected conversation graphically illustrating the inter-packet delay spacing 
between packets. Packet-to-packet delay times are shown graphically, allowing instant identification of long 
latency and response times. Retransmissions and lost packets are flagged in red for quick identification. 
The packet display can contain either a brief or detailed view of each packet’s contents.  

  
To display the connection dynamics of a conversation, right-click on any TCP or UDP Expert 
conversation to display the popup menu, choose Connection Dynamics, and the Connection 
Dynamics window for that conversation is displayed:  

  

  
  
Press the Tools button and select Find Packet. This brings up the Find dialog box that allows you to 
specify search criteria. This will quickly help you find what you are looking for in a long sequence of 
packets.  

  
Interpreting the Connection Dynamics Display  
The timeline format lets you quickly see long latencies and delayed response times. Retransmissions 
and lost packets are flagged in red.  
By right-clicking on any packet, you can:  

• jump to the Decode window display of that particular packet,  
• toggle the display packet Details on or off, or  
• change the zoom level of the Connection Dynamics window  

For example, if you see delays in query response time from a database server, it could mean that your 
server's processor is overloaded and needs to be upgraded; it could also help pinpoint problems with 
home grown (custom) applications running on servers.  

  
Important Tips:  

• If your Connection Dynamics display doesn’t show packets, it may mean they are no longer in 
the probe capture buffer. In that case you should stop the packet capture (if running) before 
using these tools so they aren’t overwritten. Press Stop. Increasing buffer size can help too.  
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Expert Analysis - Using Application Transaction Analysis (ATA)  
  

To display the Application Transaction Analysis of a conversation, right-click on any TCP or UDP Expert 
conversation to display the popup menu, choose Application Transaction Analysis.  

  

  
  
The ATA capabilities of Observer are a powerful tool for troubleshooting application issues. We have 
selected a SQL session. The Application Response Time Graph can be used for graphing 
performance metrics. We can then go into the Application Statistics of the session and see detailed 
performance metrics and statistics for each SQL request/response; notice the Response Statistics 
indicate 25 errors. By right clicking the error metric, then Show Packet List, we go to the 
request/response packets. Right click goes to the packet decode and we now see exactly what caused 
the error in the packet.  

  
Critical Application Servers should be added to Expert Analysis for ATA monitoring by right clicking an 
expert conversation and Add Server to Application Transaction Analysis. This can also be done 
from the Main menu Trending/Analysis>Application Transaction Analysis, then select Settings 
then Discover or Add. Check the Live Statistics and Network Trending Statistics checkboxes.  
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Expert Analysis – VoIP Summary and Calls  
  
To perform VoIP analysis, click the Expert Analysis tab, and then the VoIP and Video-conferencing 
button on the left side of the Expert Display.  

  
VoIP Summary Display - This display shows aggregate statistics for jitter and packet loss, as well as R- 
Factor and Mean Opinion Scores (MOS) derived from the E-model. The E-model is based on ITU-T 
Recommendation G.107, and takes into account the many types of network impairments that can 
affect voice quality. To get a more in depth explanation of the column information, right-click 
anywhere beneath the column heading to select the column then select Expert Explanation from the 
pop-up menu. In addition to providing expert explanations, right-clicking the bottom half of the display 
(the protocols summary) also allows you to create filters on the selected protocol.  

  
VoIP Calls Display - VoIP Calls tab list calls in a tree structure. By clicking on the calls listed on the left 
side of the display, you can break each one down by direction and stream of RTP/RTPC packets. For a 
description of any column, right-click anywhere beneath that column heading and choose Expert 
Explanation from the pop-up menu. Selecting a conversation will update the Expert Analysis window 
for that call (bottom). Right-clicking on a call, connection, or stream also lets you launch additional 
tools for the selected conversation.  

  
  

  
  
  
  
Important Tips:  

• Right click the RTP ID/Stream to show call play back option  
• Use Connection Dynamics to show Call manager and user station connection details.  

• Add VoIP Call manager servers to Application Transaction Analysis for detailed call information.  
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Expert Analysis – Using the VoIP Analysis Graph and Gantt Chart  
  

Whether you are setting up VoIP or troubleshooting problems with VoIP, Expert Observer gives you the 
tools you need to verify the quality of VoIP streams under various network load conditions. The VoIP 
Analysis display shows jitter and packet loss originating from both directions of a conversation charted 
against various measurements such as network bandwidth utilization.  

  
Select a call, then right click and select Analysis Graph. Then select desired stations and values to 
graph like jitter, MOS, and lost packets etc.  

  

  
  
Select Gantt Chart for a time based visualization of the VoIP components.  

  

  
  
  
Important Tips:  

1. Compress the vertical or horizontal slider bar to expand the Y or X axis scale of a graph.  
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Trending and Analysis - Overview and Setup  
  

Network trending is fundamentally different from and is run independently from packet captures or 
statistics. Trending is based on Meta-data and only requires small file sizes for storage. Observer’s 
Network Trending tool, along with the Network Trending Viewer, allows you to collect, store, view, and 
analyze network traffic statistics over long periods of time. At the software level, these two 
components function independently, meaning the Network Trending tool collects the information, and 
the Network Trending Viewer allows you to view it. Network trending provides a broad view of your 
network and gives you trending information about network applications. This information will be useful 
for solving a specific problem or can be used for long-term planning. We encourage you to spend time 
learning about the many reports that Trending and Analysis can provide.  

  
Trending can be configured to start and stop manually, run continually or be scheduled to run during 
specified days and times. Report generation and delivery can be customized in terms of detail and 
mode of delivery. These reports can then be made available to Observer and Non-Observer users by 
using a web browser. In addition to scheduling the collection of trending data, you have the ability to 
control the transfer of data from remote probes to your local Observer console.  

  
From the main menu click Trending/Analysis > Network Trending. Then click the Settings button 
to configure this feature.  

  
The General tab allows you to select what components you want to report and trend on. Your settings 
should be similar to the below. The Schedule tab allows you to specify the day(s) of the week as well 
as time period. We suggest setting it to Always. From main menu, select Options> Web Reporting 
Configuration for additional configuration options, if needed.  

  

  
  
If critical servers were not previously defined in ATA, press the Application Transaction Analysis 
button and add them now.  
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Trending and Analysis – Viewing Reports  
  

View Trending Reports by selecting Trending/ Analysis > Start Network Trending Viewer from 
the main menu. Default user = admin and password = admin 
 

 
 

 
 

  
  
We encourage you to spend time learning about the many Dashboards that Trending and Analysis can 
provide. There are system Dashboards that come standard and you can also build your own.  We suggest 
trying out the Application Performance Summary, Top IP and Application Communications, and Web 
Application Performance Dashboards. 
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Alarms and Alerts  
  

Alarms are a powerful and often overlooked feature of Observer. Using alarms, you can trigger 
predefined actions to occur when network conditions are met, making network management simpler, 
more predictable. Best of all, alarms allow you to proactively manage your network no matter where 
you are physically located.  

  
There is a large number of alarm conditions included with Observer as well as the ability to create your 
own filter based alarms. This gives you unlimited possibilities for detecting various network conditions. 
You can then designate an appropriate action base on the severity of the condition. Additionally you 
can specify an Observer function to run or execute a program such as an anti-virus program.  

  
Alarms and Alerts allow you to proactively monitor your network and immediately deal with network 
conditions. Once an alarm has been triggered, Observer can send an SNMP trap to a management 
system, log, email, or even start or stop a packet capture.  

  
Click the Alarm Settings button located in the bottom left-hand corner of main Observer window. 
Next, you can configure settings for the desired probe by highlighting it and clicking Selected Probe 
Alarm Settings. Select desired alarms from the Alarm List, then the Triggers value, then the desired 
Actions, and then Schedule.  

  

 
    
  
  
  
Important Tips:  

• Servers that are defined in Application Transaction Analysis can have response time and 
application centric alarms defined for the device. These servers will appear in the Alarm List.  
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Appendix A – Important Things to Know About Observer  
  

Probes and Probe Instances - A probe is a hardware device on your network running Network 
Instruments probe instance software. Each hardware probe has at least one probe instance that 
captures packets from your network to analyze. The probe hardware device could be a Network 
Instruments appliance, GigaStor, or Observer probe software on your own hardware. A probe instance 
is like a virtual probe and can only be used by one user at a time. Multiple probe instances can exist on 
a probe for multiple users. Keep probe instances to a minimum as each consumes memory and CPU 
resources.  

  
We suggest that you modify the default buffer size of your Observer probe (only 32 MB). Right click on 
the default probe and Administer Selected Probe. Then select Reserved Memory and Modify. 
Increase Observer reserved memory to several Gigabytes if possible. We set ours to 2 GB below. Then 
reboot.  

  

 
    
  
After the reboot right click on the default probe and Administer Selected Probe. Then select 
Memory Management, then Configure Memory (top). Increase the Packet capture buffer size to 1 
GB or more increase the statistics to 100 MB or more.  
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Packet Capture Settings- The default packet capture settings of an Observer probe are set to a circular 
buffer queue that will overwrite itself once it fills. You can modify these settings so the packets can be 
saved by writing the packets to a file.  

  
From the Main menu select Capture>Packet Capture then select Settings. Capture Options in the 
below example will save five 1 GB files and then start overwriting them when 5 GB is exceeded. Note 
that you can capture partial packets to maximize the storage if desired. From Schedule, you can 
schedule when the packet capture runs such as always or no scheduling -Start/Stop manually.  

  

 
  

  
Save Packet Captures from the Expert Analysis Window – Packets can be saved from the Expert 
Analysis window by selecting the Decode tab (bottom), then pressing Tools>Save Capture Buffer  

  
Load and Analyze a Saved Capture File – From Main menu, File> Load and Analyze Observer Capture 
Buffer  

  
Create Filters – From Main menu, Actions>Filter Setup for Selected Probe  

  
Network Ports used by Network Instruments products - Network Instruments probes and Observer use 
TCP port 25901 to transfer data and commands between the probe and the Observer analyzer. You 
may need to modify your firewall rules to allow communication on these ports for Observer.  
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Appendix B –Suggestions for Setting up an Observer Client  
  

GigaStor Control Panel Settings  
When setting up the GigaStor Control Panel, you want to eliminate as many tabs as possible that will not be 
used and enable/disable a few options that are useful and not useful.    

1. Bump up the number of MAC stations, IP pairs, possibly the IP addresses as well, also turn off 
the collection option MPLS unless you’re actually monitoring a link with MPLS tags  

2. Turn off Limit to applications defined in TCP/UDP/SCTP application definitions  
3. Turn on Collect counts for all IP protocols in addition to TCP, UDP and SCTP  
4. Deselect collection tabs like MPLS, (possibly) VLANS SCTP if they are not being used.  

Microburst is optional, but most folks won’t use it unless you’re monitoring trading floor 
applications  

5. If you’ve defined IP subnets, then turn on Display only defined subnets in IP stations tab, 
if not, then leave it unchecked.  Also, if you prefer DNS names, then check the Enable IP DNS 
resolution for GigaStor reports  
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Settings for Analyze – Viewing Settings for Expert and Decodes  
In setting up for viewing Expert Decodes, here are some suggestions:  
  

Enable the easy viewing of Connection Dynamics  
  

   

Enable the Viewing of all Connections in an Analysis Selection  
Source and Destination address display format is chosen here for the decode section as well as in all Expert 
windows – your preference for this.  If the below are checked you may not see the expected levels of traffic 
or conversations pairs showing up in Expert. These options when checked allow for only the conversations 
where a full three way handshake is seen.  
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Stream Reconstruction  
  

  
  

Packet View Settings  
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Observer General Options  
  

1. Most network engineers think in terms of bits per second 
rather than Bytes per Second (Application developers think in terms 
of bytes)  

2. If you’re dealing with a lot of big numbers, Scientific notation 
is really handy for viewing the numbers in the detail section.  

3. DCE/DTE is useful for links with TAPs, but you may prefer to 
see the port number associated with the link.  

4. If you don’t use the Navigate screen, you can turn it off from 
auto-starting when Observer opens each time.  

5. This allows for combined statistics – turn it on to grab 
aggregated statistics.  

6. Again, turn both of these on to get per station statistics as 
well as protocol statistics by MAC address.  

7. If you like the informational “packets” in your decodes 
showing utilization and other expert information, leave these 
checked.  

8. When further filtering a capture, this allows for another tab 
to be opened with only the filtered data in it, allowing you to go back 
to the original data without losing focus of the “big picture.”  

9. It’s always nice to know when a connection is made to a 
remote probe.  

This allows SNMP traps to be accepted and shown in the 
bottom   


